The Web application at http://server:port/ could not be found.

“The Web application at http://server:port/ could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application”

Here are the most common reasons this error can occur:

  1. The code is executed on a different machine – The SharePoint object model (except the Client API) requires to be run on the SharePoint server itself. It is not possible to run the application on a server which is not within the same SharePoint farm the code is trying to access.
  2. Insufficient Rights on the site collection – The code is executed in context of an account which does not have read permission on the site collection
  3. Incorrect Url being used – Verify that the site works correct in a browser and double check that the server is correct registered in the AAM settings
  4. Incorrect bitness – The SharePoint object model needs to be executed with the same bitness as the operating system. That means you cannot use the SharePoint object model in a 32-bit application if the Operating System and SharePoint are installed as 64-bit version. Ensure to compile the project using the correct bitness (64-bit on a 64-bit machine vs. 32-bit on a 32-bit machine)
  5. Incorrect .NET framework version –  Ensure that the project is configured to use .NET 3.5. .NET 4.0 cannot be used with the current versions of SharePoint

Leave a Reply

Your email address will not be published. Required fields are marked *

Bitnami